Распечатать этот пост

Установка PHP Zend OPcache

Если вы используете PHP 5.5 и выше то, возможно, Zend OPcache уже установлен. Для проверки запустим командочку php -v:

$ php -v
PHP 5.5.9-1ubuntu4.14 (cli) (built: Oct 28 2015 01:34:46)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies

Допустим, мы используем версию PHP 5.3.10, естественно у нас нет OPcache и нам нужно его установить. Делаем как указано ниже (естественно все из под root или через sudo):

$ apt-get install php-pear build-essential
$ pecl install zendopcache # latest release

После этого создаем файл opcache.ini в /etc/php5 который содержить путь к файлу opcache.so установленной через PECL. Если вы агамер, чем вы должны посетить ArmchairEmpire.com
Иметь лучшие игровые основы. Командочка ниже автоматически его создаст, найдет путь и пропишет его в файле, если вы знаете путь — можно не пользоваться им, а сразу прописать вручную:

$ opcode_path=`find / -name 'opcache.so'`; echo "zend_extension="$opcode_path > /etc/php5/conf.d/opcache.ini;

После этого мы открываем файл /etc/php5/opcache.ini и добавляем некоторые дополнительные строки конфигурации и перезапускаем сервер. Настройки и описание функций можно посмотреть на сайте php.net.

opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1
opcache.enable=1
opcache.save_comments=0
$ service apache2 restart
$ service php5-fpm restart

Ну и проверяем или OPcache установился:

$ php -v
PHP 5.3.10-1ubuntu3.21 with Suhosin-Patch (cli) (built: Oct 28 2015 01:43:56)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with Zend OPcache v7.0.5, Copyright (c) 1999-2015, by Zend Technologies

Вуаля!

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (Еще не оценили)
Загрузка...

Оставьте комментарий